python3.9中wxPython模块安装出现问题

安装wxPython使用pip命令

pip install wxPython

可能会出现些问题,如果最后提示是

WARNING: You are using pip version 19.2.3, however version 22.1 is available.
You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.

意思是:警告:您使用的是 pip 版本 19.2.3,但版本 22.1 可用。
您应该考虑通过“python -m pip install –upgrade pip”命令进行升级。

这样的话只需要再输入命令

python -m pip install –upgrade pip


升级完成,也可再检查一次

pip install wxPython


要求已经满足:wxPython in c:python 3.9.0libsite-packages (4.1.1)
要求已经满足:numpy in c:python 3.9.0libsite-packages (来自 wxPython) (1.22.3)
要求已经满足:pillow in c:python 3.9.0libsite-packages (来自 wxPython) (9.1.0)
要求已经满足:c:python 3.9.0libsite-packages 中有六个(来自 wxPython) (1.16.0)

这里提示就表明wxPython模块已经满足我们的使用要求

最后再测试下能否导入成功

python

import wx


无报错,表示可以使用了,恭喜你终于安装完成了!!!!

文章出处登录后可见!

已经登录?立即刷新

共计人评分,平均

到目前为止还没有投票!成为第一位评论此文章。

(0)
上一篇 2022年5月16日 下午2:26
下一篇 2022年5月17日 下午12:39

相关推荐

本站注重文章个人版权,不会主动收集付费或者带有商业版权的文章,如果出现侵权情况只可能是作者后期更改了版权声明,如果出现这种情况请主动联系我们,我们看到会在第一时间删除!本站专注于人工智能高质量优质文章收集,方便各位学者快速找到学习资源,本站收集的文章都会附上文章出处,如果不愿意分享到本平台,我们会第一时间删除!