PyQt5安装失败的可能原因

1. 问题描述

  1. 一开始单独在conda上创建了环境,选的是py3.7版本,使用pip install PyQt5报出一连串的错误Maybe you forgot to setup the environment
  2. 再次尝试用conda install pyqt,虽然能够成功安装,但是只能安装5.9版本的,而且无法正常使用:from PyQt5 import QtWidgetsfrom PyQt5.QtCore import *皆提示无法找到PyQt5(但是直接import PyQt5却无异常(挠头))

2. 解决

PyQt5官网发现cp36的字段,然后赶紧将python版本降级,降到3.6.3后再通过pip install PyQt5即可成功安装

文章出处登录后可见!

已经登录?立即刷新

共计人评分,平均

到目前为止还没有投票!成为第一位评论此文章。

(0)
上一篇 2022年6月15日 上午11:58
下一篇 2022年6月15日 下午12:00

相关推荐

本站注重文章个人版权,不会主动收集付费或者带有商业版权的文章,如果出现侵权情况只可能是作者后期更改了版权声明,如果出现这种情况请主动联系我们,我们看到会在第一时间删除!本站专注于人工智能高质量优质文章收集,方便各位学者快速找到学习资源,本站收集的文章都会附上文章出处,如果不愿意分享到本平台,我们会第一时间删除!