Centos7.6安装python3.7(100%成功)

Centos7.6安装python3.7(100%成功)

小白的的话可以按照教程一步一步安装成功

前言

提示:这里可以添加本文要记录的大概内容:

例如:随着人工智能的不断发展,机器学习这门技术也越来越重要,很多人都开启了学习机器学习,本文就介绍了机器学习的基础内容。

提示:以下是本篇文章正文内容,下面案例可供参考

一、查看linux版本号

命令: cat /etc/redhat-release

示例:pandas 是基于NumPy 的一种工具,该工具是为了解决数据分析任务而创建的。

二、下载、上传、安装python

1、首先要先安装依赖包:

命令:
yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gcc make

2、下载python源码包

去官方下载到本地然后上传到服务器或者wget下载,这里使用wget远程下载

wget https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz


未解决的问题:因为是国外镜像源比较慢,可以采用国内镜像源加速下载

3、移动、解压:

将下载好的python 移动到指定目录后进行解压

3.1 移动下载的安装包到/usr/local/下

mv Python-3.7.0.tgz /usr/local/

3.2解压并重命名

tar -zxvf Python-3.7.0.tgz
mv Python-3.7.0 ./python3.7

4、进入解压后的目录

cd python3.7/
./configure
make&&make install

执行完make&&make install之后,如果出现以下这种报错:

“ModuleNotFound:No module named '_ctypes'”

5、No module named ‘_ctypes 解决方案:

这里需要执行:

yum install libffi-devel -y

执行完继续make&&make install

这时候就成功了,没有任何依赖报错了

6、软连接

基本上python3.7我们就安装完成了,默认情况下,python3.7安装在/usr/local/bin/,这里为了使默认python变成python3,需要加一条软链接,并把之前的python改成python.bak:

[root@localhost python3.7]# mv /usr/bin/python /usr/bin/python.bak
[root@localhost python3.7]# ln -s /usr/local/bin/python3 /usr/bin/python

接着默认pip也是需要修改的,可以通过find / -name ‘pip3’找到pip3的位置,同样的,加一条软链到bin里面:

mv /usr/bin/pip /usr/bin/pip.bak
ln -s /usr/local/bin/pip3 /usr/bin/pip

二、配置yum

yum是依赖python2.7的,你把python改成了3.7了,自然不好使了。但是不用担心,python2.7还在你的系统里。只要修改一下yum里的相关依赖即可。

vi /usr/libexec/urlgrabber-ext-down

找到一个/usr/bin/python的,后面加上2.7就可以了!也就是/usr/bin/python2.7,然后wq保存;

vi /usr/bin/yum

三、验证:

[root@localhost python3.7]# python -V
Python 3.7.0
[root@localhost python3.7]# pip -V
pip 10.0.1 from /usr/local/lib/python3.7/site-packages/pip (python 3.7)
[root@localhost python3.7]# python
Python 3.7.0 (default, May 19 2022, 17:24:37) 
[GCC 4.8.5 20150623 (Red Hat 4.8.5-44)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> 

四、测试安装其他包

例如安装 pytest包

[root@localhost python3.7]# pip install json
Looking in indexes: https://pypi.tuna.tsinghua.edu.cn/simple
Collecting json
  Could not find a version that satisfies the requirement json (from versions: )
No matching distribution found for json
You are using pip version 10.0.1, however version 22.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

需要更新pip 刚安装的pip 版本太低了

pip install --upgrade pip


继续安装包 pytest

[root@localhost python3.7]# pip list
Package            Version
------------------ -------
attrs              21.4.0
importlib-metadata 4.11.3
iniconfig          1.1.1
packaging          21.3
pip                22.1
pluggy             1.0.0
py                 1.11.0
pyparsing          3.0.9
pytest             7.1.2
setuptools         39.0.1
tomli              2.0.1
typing_extensions  4.2.0
zipp               3.8.0

五、总结

遗留问题:下载python包的时候采用的国外镜像源 下载python得包比较慢
该教程100%可以安装成功哈

文章出处登录后可见!

已经登录?立即刷新

共计人评分,平均

到目前为止还没有投票!成为第一位评论此文章。

(0)
上一篇 2022年5月20日 下午2:08
下一篇 2022年5月20日 下午2:12

相关推荐

本站注重文章个人版权,不会主动收集付费或者带有商业版权的文章,如果出现侵权情况只可能是作者后期更改了版权声明,如果出现这种情况请主动联系我们,我们看到会在第一时间删除!本站专注于人工智能高质量优质文章收集,方便各位学者快速找到学习资源,本站收集的文章都会附上文章出处,如果不愿意分享到本平台,我们会第一时间删除!