错误:无法为 spacy 构建轮子,这是安装基于 pyproject.toml 的项目所必需的

乘风 nlp 1760

原文标题ERROR: Could not build wheels for spacy, which is required to install pyproject.toml-based projects

enter image description here

嗨,伙计们,我正在尝试安装 spacy 模型 == 2.3.5,但出现此错误,请帮助我!

原文链接:https://stackoverflow.com//questions/71512301/error-could-not-build-wheels-for-spacy-which-is-required-to-install-pyproject

回复

我来回复
  • aab
    aab 评论

    尝试使用 python 3.6-3.9,其中有二进制轮子供pip install使用,而不必从源代码编译。

    (这是与python 3.10和源码包中一些生成的.cpp文件冲突。这个版本发布的时候Python 3.10还没有发布。)

    1年前 0条评论
  • Talha Tayyab
    Talha Tayyab 评论

    尝试使用:

    !pip install spacy==2.3.5

    ==2.3.5之间不要留空格

    如果您在等号和版本之间留出任何空格,则可能会出错。

    1年前 0条评论