numpy,matplotlib,python的版本对应(implement_array_function method already has a docstring报错)

**********写在前面*********

在我们开始之前,先把numpy,matplotlib卸载干净(同一个包可能会装两个不一样版本),所以同一句卸载指令我们要执行到找不到这个包为止(%%%%%%—–重要——%%%%%)

pip uninstall numpy
pip uninstall matplotlib

接下来上干货

https://matplotlib.org/devdocs/devel/min_dep_policy.html

该链接查看三者版本对应关系

直接上图

然后我用的是conda环境,使用如下代码

conda install numpy
conda install matplotlib

他会自己匹配对应的版本,结束

(补充–第二版)

我发现有些时候numpy和matplotlib无论什么版本都会冲突,这件事发生在这篇博客第一版发表后的几天,困扰了我好久,我用的是tensorflow的深度学习框架用来图像识别,所以同时下载了pytorch,这三个库由于某种原因关系交织在一起非常乱,所以我直接把matplotlib卸了不再使用,

原先的报错语句

from matplotlib import transforms

我改成了下面的

from torchvision import transforms

 发现也能用,果断删掉matplotlib,后来我找到了其他方法,我就放弃这条路了,结果非常成功(也可能bug在后面等我)

本站持续更新,我不用matplotlib了这篇博客out了,后续号上可能会分享些其他的深度学习内容,本人24届苦逼大四生,毕设ing……….《基于tensorflow的XX识别系统》加油!!!!

———————————————————————————————————————–

(补充–第三版)

在使用如下语句时发生报错(已安装matplotlib==3.7)

import matplotlib.pyplot as plt

提示没有pyplot库,以为又是版本兼容的问题,在anaconda中和prompt中又卸载了一次,看到某博主说是3.X版本的原因让降到2.X版本,结果虚拟环境不让装(在不改变之前其他库版本的条件下),于是又重装了对应版本的matplotlib(在conda虚拟环境中),结果重启pycharm后没报错了,估计又是引导什么的问题,大家遇到同样的问题可以和我一样试试

版权声明:本文为博主作者:m0_61773745原创文章,版权归属原作者,如果侵权,请联系我们删除!

原文链接:https://blog.csdn.net/m0_61773745/article/details/136245403

共计人评分,平均

到目前为止还没有投票!成为第一位评论此文章。

(0)
青葱年少的头像青葱年少普通用户
上一篇 2024年5月6日
下一篇 2024年5月6日

相关推荐