BERT-base 模型关于tensorflow版本不匹配问题

tensorflow高版本适配低版本解决方法

IDE: PyCharm
tf版本: 2.9

运行bert模型

出现报错module ‘tensorflow._api.v2.train’ has no attribute ‘Optimizer’

根本原因是tensorflow 1的版本与2不适配

将class AdamWeightDecayOptimizer(tf.train.Optimizer)

改为

module ‘tensorflow._api.v2.train’ has no attribute ‘Optimizer’

当前来看适用于一切tensorflow 1的版本与2不适配的问题

文章出处登录后可见!

已经登录?立即刷新

共计人评分,平均

到目前为止还没有投票!成为第一位评论此文章。

(0)
上一篇 2022年5月22日 下午3:06
下一篇 2022年5月22日 下午3:10

相关推荐

本站注重文章个人版权,不会主动收集付费或者带有商业版权的文章,如果出现侵权情况只可能是作者后期更改了版权声明,如果出现这种情况请主动联系我们,我们看到会在第一时间删除!本站专注于人工智能高质量优质文章收集,方便各位学者快速找到学习资源,本站收集的文章都会附上文章出处,如果不愿意分享到本平台,我们会第一时间删除!